All systems operational

Delayed outbound Email sending to some providers

Resolved
Degraded performance
Started about 2 years ago Lasted about 2 hours

Affected

Outbound Channels
Email Sending
Updates
  • Resolved
    Resolved

    Sending is back to normal. This was communicated by upstream networks and we have confirmed we are seeing normal delivery times for campaigns and transactional OTPs.

  • Monitoring
    Monitoring

    We continue to monitor upstream networks for improved delivery times and have rerouted some of our mail queues to improve email delivery performance for our customers.

  • Identified
    Identified

    We have identified an upstream incident that has caused delays to Email delivery to some providers including Gmail, Hotmail, Yahoo and AOL. These delays can be in excess of 5 mins for delivery.

    We continue to seek updates from our upstream providers and are in the process of rerouting email queues.