All systems operational

SMS Delivery Delays

Resolved
Degraded performance
Started over 2 years ago Lasted 13 minutes

Affected

Platform
Portal
Outbound Channels
SMS Sending
Updates
  • Resolved
    Resolved

    They have confirmed the issue was resolved and we are seeing expected latency and delivery times on our side.

  • Identified
    Identified

    Our upstream SMS provider executed some unannounced and unplanned emergency maintenance causing API requests to timeout or fail.

  • Investigating
    Investigating

    We are currently investigating this incident with our upstream provider. This affects all SMS's (Including passcodes and SMS campaigns)