All systems operational

Longer than expected Email Delivery Times for some customers

Resolved
Degraded performance
Started over 2 years ago Lasted 25 minutes

Affected

Outbound Channels
Email Sending
Updates
  • Resolved
    Resolved

    Email queue is clear and delivery rates are back to below 10 seconds.

  • Monitoring
    Monitoring

    Throttle removed and email queue is clearing rapidly. We will continue to monitor performance before marking this as resolved.

  • Identified
    Identified

    We have identified the upstream provider has throttled some outbound emails to review for spam or fraudulent emails. We are working with them to clear the email queue.

  • Investigating
    Investigating

    We are currently investigating this incident.