All systems operational

Upstream provider latency causing Slower than normal email delivery

Resolved
Degraded performance
Started almost 3 years ago Lasted about 2 hours

Affected

Outbound Channels
Email Sending
Updates
  • Resolved
    Resolved

    Delivery times have returned to a normal delivery speed

  • Monitoring
    Monitoring

    Delivery times have returned to under 10 seconds for major providers. We are continuing to monitor and seeking an update from upstream providers.

  • Identified
    Identified

    An upstream provider is experiencing increased latency, resulting in emails taking up to 100 seconds to land in an inbox.

  • Investigating
    Investigating

    We are currently investigating this incident with our upstream provider