Jomablue - Issue adding e-Tickets to Apple Wallet – Incident details

All systems operational

Issue adding e-Tickets to Apple Wallet

Resolved
Operational
Started about 2 months agoLasted 2 days

Affected

Platform

Operational from 9:53 PM to 2:27 AM

Registration

Operational from 9:53 PM to 2:27 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. While there were three seperate issues, only a subset of users - in very specific scenarios that would have been affected by this issue.

    There were a number of issues affecting adding the e-Tickets to Apple wallet for a subset of users. Firstly, there was an encoding issue with non-latin based characters and the handling of them within the Apple wallet pass - specifically around two byte characters. This has been resolved.

    Secondly, adding e-Tickets to the Apple wallet from Slack's in-app web browser would fail. We found no specific evidence why link handling has changed within Slack's in-app browser but have evidence it has - we have resolved this by changing handling of the 'Adding to Wallet' functionality to continue to support in-app browsers.

    Finally, we uncovered that for iOS users with hundreds of Safari tabs open - there is not resources for the device/browser to process the generation and adding of the pass to the wallet. This is some undocumented limitation, but from our testing, exceeding hundreds of tabs would cause the adding of the pass to the wallet to silently fail. Reducing the number of tabs in Safari would resolve the issue.

  • Identified
    Identified

    We have identified the cause and are working on a change. We will provide some more information in the next update.

  • Investigating
    Investigating

    We are currently investigating this incident that affects some e-Ticket recipients. These users are unable to add the e-Ticket to their Apple wallet on iPhones. The e-Ticket still remains functional and can be used for admittance to events - this is specific to adding that to Apple Wallet. Will will continue to update here as new information comes to hand.