Jomablue - Email Delivery Delays – Incident details

All systems operational

Email Delivery Delays

Resolved
Degraded performance
Started 14 days agoLasted about 4 hours

Affected

Outbound Channels

Degraded performance from 3:57 AM to 7:51 AM

Email Sending

Degraded performance from 3:57 AM to 7:51 AM

Updates
  • Resolved
    Resolved

    This has been resolved, all pending emails were queued and now have been delivered. We are working with the upstream provider to produce a autopsy and ensure we can consider how Jomablue can be more resilient to such upstream provider issue.

    If you have any further questions we can answer them, just reach out to support.

  • Identified
    Identified

    We have identified an issue with an upstream provider for specific email queues. We have escalated the issue and are working with the upstream provider to resolve.

    Jomablue emails are split between Transitional and Broadcast/Marketing emails automatically ensuring high delivery rates across all your email communications. In this particular case, the Broadcast/Marketing emails are affected but transactional emails - such as for invoices, OTP's etc remain unaffected.


    We will continue to update here as we learn more and work towards a resolution with our upstream provider.

  • Investigating
    Investigating

    We are currently investigating delayed delivery of emails. We will continue to post updates here as more information comes to hand.