Jomablue - Email Delivery Delays – Incident details

All systems operational

Email Delivery Delays

Resolved
Operational
Started 6 months agoLasted about 2 hours

Affected

Outbound Channels

Operational from 6:08 PM to 8:23 PM

Email Sending

Operational from 6:08 PM to 8:23 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. All queued messages have now been sent and delivery times have returned to normal.

  • Identified
    Identified

    Outbound emails are currently being queued for delivery - causing a delay in them reaching inboxes. The queueing is happening upstream of Jomablue and we are working with an upstream provider to restore expected delivery times. No messages have been lost and will be sent.